Get in touch
Back
Maintenance

Scheduled Maintenance - 28th March

Completed .

Dashboard Userflow.js End-user server (US) End-user server (EU) API (US) API (EU) Background workers Website
Completed

Maintenance completed

Posted .
Started

We will perform a minor scheduled update on March 28, starting at 2:30 AM GMT (March 27, starting at 10:30 PM EST) for approximately 10 minutes. During this time you may experience a brief disruption in service.

We appreciate your patience as we work to improve Userflow.

Updated Completed as planned

Posted .